Azure VM Scheduler tasks not running

Blog Azure

Azure VM Scheduler tasks not running

Azure VM Scheduler tasks

If you are having any issues with the Azure VM Scheduling tool not running a scheduled task, it could be one of the following issues

First thing to check is your log file which is located in the following location:

C:Program Files (x86) – SMIKAR Software – AVMS – avms.log

Error 1:

Scour through the log file and look for something similar to below:

01/11/2016 11:23:46 AM Attempting to ADD-azureaccount using account XXXX@XXXX.onmicrosoft.com
01/11/2016 11:23:46 AM Failed to ADD-azureaccount using account XXXX@XXXX.onmicrosoft.com – error user_realm_discovery_failed: User realm discovery failed: The remote server returned an error: (407) Proxy Authentication Required.

So the issue in the above example is that your onsite proxy server requires authentication to allow AVMS to talk to Azure.

The reason why the AVMS console can connect to Azure is because it is running under your own Domain Account and has the appropriate permissions to use the proxy server. The scheduled task however runs under your computers system account and more than likely does not have this permission.

So how do you fix this you ask?

Well go in to your control panel, then in to scheduled tasks. Highlight the AVMS task, right click it and choose properties.

Azure VM Scheduler Tasks

Next you need to change the user account from System to a domain and proxy appropriate account with the highest privileges you can.

Azure VM Scheduler tasks 2

AVMS will now run its scheduled tasks.

Error 2:

Again through the log another possible error to look out for is;

01/11/2016 12:45:23 PM Attempting to ADD-azureaccount using account XXXX@XXXX.onmicrosoft.com
01/11/2016 12:45:23 PM Connected to ADD-azureaccount using account XXXX@XXXX.onmicrosoft.com
01/11/2016 12:46:56 PM Attempting to ADD-AzureRmAccount using account XXXX@XXXX.onmicrosoft.com
01/11/2016 12:46:56 PM Connected to ADD-AzureRmAccount using account XXXX@XXXX.onmicrosoft.com
01/11/2016 12:46:56 PM Started code block to Stop VMs
01/11/2016 12:46:56 PM Adding servers to array for email
01/11/2016 12:46:56 PM email form created notifying task has started

If your log file stops as shown in the above, it is your email settings that are causing AVMS to not progress any further. Please check and confirm your email settings are correct, alternatively turn off notifications. Please be warned, turning this off will result in you not receiving any emails from the AVMS software.